Home » hotfixes

Tag: hotfixes

James's Super Amazing Hotfix Post

Windows 2008 x64 SP1 – (NON R2)

http://support.microsoft.com/kb/2379016 – A computer that is running Windows Vista or Windows Server 2008 stops responding and hangs at the “Applying User Settings” stage of the logon process (Fix Stuck at Welcome screen)

http://support.microsoft.com/kb/974878 – PhysicalDisk counters contain invalid and duplicate entries when you use Microsoft Multipath I/O (MPIO) to control one or more storage devices (Fix for Oracle EM to graph disk access)

Windows 2008 x64 R2 SP1 (Terminal Services, Remote Desktop Services)

http://support.microsoft.com/kb/2617858 – Unexpectedly slow startup or logon process in Windows Server 2008 R2 or in Windows 7*
http://support.microsoft.com/kb/2620656 – Invalid redirected printers may be available in a Remote Desktop Services session that connects to a RD Session Host server that is running Windows Server 2008 or Windows Server 2008 R2*
http://support.microsoft.com/kb/2578159 – The logon process stops responding in Windows Server 2008 R2 or in Windows 7
http://support.microsoft.com/kb/2551503 – A mapped drive that has the non-persistent flag set is displayed as a disconnected drive in Windows 7 or in Windows Server 2008 R2
http://support.microsoft.com/kb/2444328 – You cannot access shared files or shared printers in Windows 7 or in Windows Server 2008 R2
http://support.microsoft.com/kb/917607 – I cannot open Help that was created in the Windows Help format (WinHlp32.exe)
http://support.microsoft.com/kb/2465772 – An application or service that uses Winsock API or Winsock Kernel API may randomly stop responding in Windows Server 2008 R2 or in Windows 7
http://support.microsoft.com/kb/2661001 – “Please wait for Local Session Manager” message remains for several minutes when you disconnect from a computer that is running Windows Server 2008 R2 during the logon process
http://support.microsoft.com/kb/2590550 – The desktop does not load and only displays a black or blue background after you log on to a computer that is running Windows 7 or Windows Server 2008 R2

Windows 2008 x64 R2 POST SP1 (Terminal Services, Remote Desktop Services)

http://support.microsoft.com/kb/941158 – In an Active Directory service domain environment, you configure the Internet Explorer Maintenance Group Policy settings. A user logs on to the domain from a Windows XP-based, a Windows Server 2003-based, or Windows Vista-based client computer that has Internet Explorer 7 or Internet Explorer 8 installed. ever, the user experiences a 20-second logon delay compared with a client computer that has Internet Explorer 6 installed.
http://support.microsoft.com/kb/2571388 – You install the Remote Desktop Session Host role service on a computer that is running Windows Server 2008 or Windows Server 2008 R2. You try to log off a Remote Desktop Services session on the computer. In this scenario, the Remote Desktop Services session stops responding. After some time, the computer stops accepting incoming Remote Desktop Protocol (RDP) or Independent Computing Architecture (ICA) connections. You must turn off and then restart the computer to recover from this issue.
http://support.microsoft.com/kb/2661001 – On Servers running Windows 2008 R2, the following error messages are displayed during the logon process: “Please wait for Local Session Manager”, “The task you are trying to do cannot be completed because remote desktop services is currently busy”.
http://support.microsoft.com/kb/2465772 – An application or service that uses Winsock API or Winsock Kernel API might randomly stop responding in Windows Server 2008 R2.
http://support.microsoft.com/kb/2444328 – You cannot access shared files or shared printers in Windows 7 or in Windows Server 2008 R2.
http://support.microsoft.com/kb/2551503 – A mapped drive that has the non-persistent flag set is displayed as a disconnected drive in Windows 7 or in Windows Server 2008 R2.
http://support.microsoft.com/kb/2578159 – The logon process stops responding in Windows Server 2008 R2 or in Windows 7.
http://support.microsoft.com/kb/2620656 – Invalid redirected printers may be available in a Remote Desktop Services session that connects to a RD Session Host server that is running Windows Server 2008 R2.
http://support.microsoft.com/kb/2617858 – Unexpectedly slow start-up or logon process in Windows Server 2008 R2 or in Windows 7.
http://support.microsoft.com/kb/917607 – When you try to use Help in some programs on a computer that is running Windows 7 or Windows Server 2008 R2, you may receive an error.
http://support.microsoft.com/kb/977346 – The Welcome screen may be displayed for 30 seconds during the logon process after you set a solid colour as the desktop background in Windows 7 or in Windows Server 2008 R2.
http://support.microsoft.com/kb/2551503 – A mapped drive that has the non-persistent flag set is displayed as a disconnected drive in Windows 7 or in Windows Server 2008 R2.
http://support.microsoft.com/kb/2775511 – An enterprise hotfix rollup is available for Windows 7 SP1 and Windows Server 2008 R2 SP1.
http://support.microsoft.com/kb/2647753 – Update rollup: Fix printing problems in Windows 7 and Windows Server 2008 R2.
http://support.microsoft.com/kb/2661332 – You cannot re-establish a Remote Desktop Services session to a Windows Server 2008 R2-based server.

Citrix XenAPp 6.5 on Windows 2008 R2 x64

http://support.citrix.com/article/CTX132912 – XA650W2K8R2X64025*

http://support.citrix.com/article/CTX132392 – XA650W2K8R2X64019*

http://support.citrix.com/article/CTX130794 – XA650W2K8R2X64001*

http://support.citrix.com/article/CTX131486 – XA650W2K8R2X64011*

http://support.citrix.com/article/CTX132789 – XA650W2K8R2X64023
http://support.citrix.com/article/CTX130989 – XA650W2K8R2X64004
http://support.citrix.com/article/CTX131221 – HDXWMIPROV620W2K8R2X64001
http://support.citrix.com/article/CTX130971 – Hotfix XA650W2K8R2X64002
http://support.citrix.com/article/CTX131837 – Hotfix XA650W2K8R2X64014
http://support.citrix.com/article/CTX131456 – Hotfix GPMx150WX64002

Microsoft Updates on Citrix XenApp 6.5 on Windows 2008 R2 x64 Post RO4
KB2647753

KB2775511

KB917607

KB2620656

KB2465772

KB2661332

Citrix Webinterface 5.4

http://support.citrix.com/article/CTX130660 – Hotfix WI540MSI002 – For Citrix Web Interface 5.4 for Windows – Issues with WI load balancing

http://support.citrix.com/article/CTX117273 – KB Article to Fix ASP.net Slow Web Interface Initial Load times

Citrix Edgesight 5.4

http://support.citrix.com/article/CTX131261 – ES540XA6AgentWX64001

http://support.citrix.com/article/CTX131172 – ES540ServerWX64001

http://support.citrix.com/article/CTX131171 – ES540ServerWX86001

Windows 2003

Terminal Services http://support.microsoft.com/kb/977629

RDBSS http://support.microsoft.com/kb/983169

WMI Stability http://support.microsoft.com/kb/2257980

TCP/IP http://support.microsoft.com/kb/2909312

SMB http://support.microsoft.com/kb/961799

NTFS http://support.microsoft.com/kb/981166

RDP Client http://support.microsoft.com/KB/925876 http://support.microsoft.com/KB/2481109

Windows 2008 SP2 hangs at Applying Computer Settings

Situation: Windows 2008 SP2 Standards Servers on ESX 4.0 Vm’s. The servers had non persistent disks and every monday revert to their original image. The VM’s were recently changed to have 2 vCPU’s.

Problem: Come the Monday morning reset all the servers stopped responding and were hanging at boot up on ‘Applying Computer Settings’ and for user logons ‘Applying user settings’

After setting the server to persistent and getting the event logs the following was the only obvious error logged

The winlogon notification subscriberis taking long time to handle the notification event (StartShell).

Solutions: There is a MS article for the listed problem which simply sets a dependency of the ‘HTTP service’ to wait for the ‘Cryptographic Services’

http://support.microsoft.com/kb/2379016 Applying this registry key or hotfix (we did both to two separate servers) seems to have resolved the errors

References:

http://social.technet.microsoft.com/Forums/en-US/itprovistanetworking/thread/56310e15-32df-457a-bc38-4cc2fce0a5e5/

http://support.microsoft.com/kb/2004121

http://support.microsoft.com/kb/2379016

 

Post XenApp 5 R01 x64 Windows 2008 Hotfixes

Problem:
After the installation of R01 for XenApp 5.0 on Windows x64 2008 – Outlook and PDF links stopped working.

Fix:
Install the Citrix provided post R01 hotfix here – http://support.citrix.com/article/CTX129366

Additional:
For some users this fix was not enough as they had already saved the blank associations in their profile

we had to delete the following keys
HKCUSoftwareMicrosoftWindowsShellAssociationsUrlAssociationsHTTP and HTTPS

References:
R01 Details – http://support.citrix.com/article/CTX125419
Post R01 Hotfix 022 –http://support.citrix.com/article/CTX129366
Citrix Forum with further details – http://forums.citrix.com/message.jspa?messageID=1529074#1529074