Home » KBArticles » Citrix XenApp 6.5 session sharing broken through Secure Gateway 3.1.2

Citrix XenApp 6.5 session sharing broken through Secure Gateway 3.1.2

Problem:

When launching PNAgent apps from a published desktop the session sharing would intermittently break.

When running the desktop inside the network, it would generally behave, externally via the Citrix Secure Gateway the session sharing wouldn’t work, a separate session would launch for most if not all of the Citrix applications published via PNAgent or the app wouldnt start at all.

Some apps would work and not others. I deleted any non working apps, copied a working application and renamed / resetup the application and that application would launch for a time.

The following KB articles and sites were visited and their fixes were implemented first.

http://support.citrix.com/article/CTX126839 – How to Set Up Session Sharing Precedence Over Load Balancing in a XenApp Farm

http://support.citrix.com/proddocs/topic/xenapp65-admin/lm-using-attach-loadval-all.html – Changed the server LB policies (I only had the default rule assigned)

Delete and recreated the applications fresh *this worked for a time.

But after numerous attempts of logging in with fresh profile or existing users – the experience wasnt consistent, and still breaking via Secure Gateway.

Solution:

We were running PNAgent 12.1.44.1 on the published desktop, an upgrade to 12.3.0.8 of the citrix online plugin fixed these session sharing issues.

*We were avoiding the upgrade to the receiver at this stage as there was no storefront (though its not required) and the CIO still requires the users to have dynamic start menu, desktop and taskbar icons to launch applications.

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.